ChromeSi vous utilisez Google Chrome, il se peut que vous ne parveniez plus à ouvrir la page http://www.frank-poupart.org/blog/ sans que Chrome ne plante comme une merde. En fait, la page charge indéfiniment et le navigateur ne répond plus.
Dans certains cas ce message d’erreur apparaît mais, que l’on choisisse d’attendre ou de fermer la page, Chrome reste bloqué.

Je pense que ce bug se produit depuis la dernière mise à jour de Chrome (i.e. le 23 janvier, version 16.0.912.77) et qu’il résulte d’un conflit entre le plugin WordPress Flash Video Player et la gestion de Flash par Chrome (vous observerez que les pages du blog sans composant Flash continuent de s’ouvrir parfaitement).
J’ai désinstallé et réinstallé Chrome : pas mieux. Riton m’a confirmé que Chrome plantait aussi chez lui. Notez que nous sommes sous Windows 7, j’ai pas testé avec un OS antérieur.

Comme j’utilise en parallèle quatre navigateurs différents*, je sais que c’est un problème propre à Chrome sous Windows (RAS avec Firefox, IE, Safari et même Chrome sous Mac Snow Leopard !). J’ai un peu creusé le truc et j’ai trouvé une rustine, en attendant qu’une prochaine release Chrome corrige éventuellement ce bug, ou que je change de player (ça me ferait mal).

Pour gérer le Flash, Chrome s’appuie sur deux plugins, celui distribué par Adobe et un plugin maison.
Ces plugins font sensiblement le même boulot et il n’est pas nécessaire d’activer les deux (mais ils le sont par défaut). Je vous propose donc la manip suivante :

1. Ouvrez Chrome, tapez « chrome://plugins » dans la barre d’adresse et validez.

2. Cliquez sur le lien « Détails », comme indiqué sur la capture d’écran ci-dessous.

Screenshot Chrome Plugins

3. Repérez les composants Flash et désactivez-les, comme indiqué sur la capture d’écran ci-dessous (la désactivation se matérialisera par un effet grisé sur les composants).

Screenshot Chrome Plugins

4. Ouvrez un nouvel onglet et lancez la page http://www.frank-poupart.org/blog/
En lieu et place des vidéos, vous devriez trouver le message : « Get the Flash Player to see this content. »

5. Revenez sur l’onglet « Plug-ins » et réactivez le composant Flash Adobe (NPSWF32.dll), pas celui de Chrome.

6. Relancez la page http://www.frank-poupart.org/blog/ Bingo !

Là, le mec qui a un tant soit peu suivi brûle de me dire : « C’était pas plus simple de désactiver directement le composant Flash de Chrome à l’étape 3 ? » Bah oui mais en fait non… ça merde. Ne me demandez pas pourquoi.

Le truc lourd, c’est qu’il faut recommencer à chaque démarrage de Chrome (d’où le nom de « rustine »).

Si pas bingo (j’en connais qui ont pas de chatte), videz le cache de Chrome en procédant comme suit :
En haut à droite de l’interface, cliquez sur la clé à molette ;
Cliquez sur « Options » ;
Dans le menu de gauche, cliquez sur « Options avancées » ;
Dans la partie « Confidentialité », cliquez sur « Effacer les données de navigation » ;
Cochez les cases « Vider le cache » et « Supprimer les cookies et autres données de site et de plug-in » (décochez les autres), puis cliquez sur « Effacer les données de navigation ». Pour finir, recommencez les étapes 1 à 6.

Si vraiment rien n’y fait (atroce), reste une deuxième méthode, beaucoup plus radicale : utilisez Firefox (ou n’importe quel autre bouzin qui navigue sauf Chrome).

De mon côté je vais voir si je peux arranger ça…
Si quelqu’un a une idée, je prends aussi.

*C’est pas que je suis parano mais il faut savoir que chaque moteur de rendu est différent et qu’il y a parfois des écarts notables entre navigateurs.
Par exemple, le profil colorimétrique de Chrome est différent de celui de Firefox : une photo apparaîtra plus saturée dans Firefox que dans Chrome (faites l’expérience, vous pourriez être surpris). Depuis que je m’en suis rendu compte, et vu que je ne suis pas très stable mentalement, j’essaie toujours de trouver un juste milieu lors du post-traitement de mes images afin que ces dernières aient à peu près la même gueule dans tous les navigateurs.
Et je ne vous parle pas des autres différences (liées notamment au respect des langages de programmation).

3 commentaires sur “Rustine pour Chrome”
  1. Heg dit :

    T’es un grand malade Poupart. Mais ça marche.

  2. Dominique dit :

    En tout cas sur mon Mac équipé de Chrome, pas de souci.

  3. Le prof dit :

    Ouaip, même problème et sur plusieurs OS antérieurs. En attendant une solution durable j’utilise Firefox même si, effectivement, j’aime moins le traitement des couleurs.

  4.  
Je commente, je flatte, je tacle...